Chichester Mini Club Forum

For all local classic mini owners


    Car Won't Drive In First For Very Long

    Share
    avatar
    duds_12

    Posts : 17
    Join date : 2010-04-22

    Car Won't Drive In First For Very Long

    Post  duds_12 on Mon Dec 06, 2010 10:20 am

    i have changed the engine on my mini about a month ago to a metro engine
    the other day trying to drive it home i selected first and pulled away but when i pressed the clutch down and took my foot off the accelerator and the let the revs drop the whole car just locked up (it didn't stall but just physically stopped the wheels from turning but the engine was still running )
    when i tried to drive it in reverse it really struggled but could still go.
    i managed to get the car home by pulling off in 3rd gear (3rd and 4th gear are fine)
    not sure about 2nd gear.
    i firstly but it down to the top engine stabiliser bolt breaking allowing the whole engine to move
    this is now fixed and the engine doesn't move but i still have the same problem.
    would it be something with the clutch (pressure plate etc) or would it be the gearbox/diff that's the problem?
    or could i have bent the selector rods and they're causing this problem?
    please help
    avatar
    clintminimad

    Posts : 56
    Join date : 2010-03-24
    Age : 39
    Location : lavant

    Re: Car Won't Drive In First For Very Long

    Post  clintminimad on Mon Dec 06, 2010 11:40 am

    sounds like its your gearbox that has gone. just do a swap with your old engines gearbox
    avatar
    steble

    Posts : 328
    Join date : 2010-03-24
    Location : rose green

    Re: Car Won't Drive In First For Very Long

    Post  steble on Tue Dec 07, 2010 1:49 pm

    agreed

    Sponsored content

    Re: Car Won't Drive In First For Very Long

    Post  Sponsored content


      Current date/time is Fri Aug 17, 2018 9:35 am